Follow

Recommended internet browsers

The ELMS runs optimally through the internet browsers Google Chrome and Mozilla Firefox. While you can still connect with the ELMS using Internet Explorer and Safari, these browsers can sometimes cause small errors within the ELMS. 

You can download Google Chrome here: https://www.google.com/chrome/ 
by using the download option in the top menu bar and selecting your device type.

You can download Mozilla Firefox here: https://www.mozilla.org/en-US/firefox/new/

We also recommend to update your internet browser regularly, to ensure they are working correctly.

Was this article helpful?
0 out of 0 found this helpful
Have more questions? Submit a request

0 Comments

Article is closed for comments.